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MobileMapper Office Background Map FAQ 
14 February 2007 
 
How do I create a background map using vector GIS files? 

1. On the menu bar, select Tools and then Background Maps. This opens the 
Background Maps window. 

2. Click the Vector Maps tab near the top of the Background Maps window. 
3. Click the Map Editor... button. This opens the Vector Map Editor window from 

which you can create a new background map by importing vector GIS files. 
4. Type in a name for the background map in the Map Name field. 
5. The default Map Scale is 1:100,000. If you are a first time user, you can leave 

this alone and go to Step 6. If you are interested, there are some FAQs below on 
the subject of map scales. 

6. Click on Layer > Add (or click the Add Layers icon) to add a layer to your map. 
This action displays a browsing window. 

7. Go to the directory where you have stored the file that you want to insert as a 
layer in the background map. 

8. In the Files of type field click the format of the file that you want to add. 
9. Click the file name you want to add. 
10. You must select the coordinate system that the file is in. MobileMapper cannot 

import a file into a background map without first knowing what coordinate 
system/datum the file is in. (If you import a shapefile that includes a .prj file, 
MobileMapper Office will automatically select the coordinate system.) You can 
use your GIS to determine what this coordinate system/datum might be. 

11. Click on Open to add this file as a layer to the background map. 
12. The map symbol that will be used to display this layer is indicated on the Vector 

Map Editor window. You can select other symbols, line attributes, colors, etc. by 
double-clicking on the layer name. 

13. Select one of the layer’s attributes to display on the receiver, for example the 
name of a road. The value for this attribute, e.g. a street’s name, will appear on 
the receiver when you move the map cursor over the feature. Note: 
MobileMapper Office does not import block attributes from AutoCAD DXF files, 
so you cannot select attributes to display. If you wish to display such an attribute, 
export the data from AutoCAD as a shapefile and import that. 

14. Select other layers you want to add to the background map, if any. You can select 
which layers will be displayed on top of the other layers by using the Layer > 
Move Up and Move Down commands. 

15. When you are done adding layers, select File and then Save or Save As. In the 
dialog box that opens, choose a folder and enter a name for the background map 
file you want to create. This file will have the “mmp” extension. 

16. Then click Operations > Create Map to create the file. 
17. After the new map has been created, click on File > Exit to return to the 

Background Maps window. 
18. The new map is highlighted (there is a paper clip icon next to it). Click on OK 

and the background map will be displayed in the Map Display area. 
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What types of GIS files can I use to create a vector background 
map? 
You can import ESRI shapefiles, MapInfo MIF files and Autodesk DXF files into a 
background map.  You can upload vector background maps into the MobileMapper Pro 
and ProMark3 receivers. 
 
How do I create a background map using raster images? 
You can create a background map by importing raster images, both georeferenced and 
unreferenced, in much the same way as you would create a map from vector files. There 
are two differences: you cannot select different map scales for displaying the layers and 
you must georeference each layer. The User Manual uses graphics to help visualize the 
process of georeferencing and so we suggest you refer to it by going to MobileMapper 
Office, clicking on Help and selecting the User Manual menu item. 
Please note that the MobileMapper Pro and ProMark3 receivers’ map display engines do 
not support raster background maps. You can upload only those background maps you 
have made from vector files. 
 
What raster formats can I import into a MobileMapper Office 
background map? 
GeoTIFF (*.tif, *.tiff, *.gtif), BMP, JPEG (*.jpg, *.jpeg), PNG and GIF. 
 
Can I create a background map using both vector files and 
raster images? 
Yes. After opening the Background Maps dialog box, click on either the Vector Map or 
Raster Map tab, select the name of the background map you want to view and click the 
Attach button. A clip icon appears before this name indicating that the attachment is now 
effective. You can only attach one map on each of each type. MobileMapper Office 
always displays the vector map on top of the raster image. Please note that the 
MobileMapper Pro and ProMark3 receivers’ map display engines do not support raster 
background maps. You can upload only those background maps you have made from 
vector files. 
 
When importing a GIS file into a background map, what should 
I do if I see the following error message: “Error on opening 
[GIS file name]. File coordinates are not in lat/log degrees. 
Make sure the selected coordinate system for this file is 
correct.” 
On the file import screen, you must tell MobileMapper Office what coordinate system 
and datum are used to display the GIS file, e.g. UTM North, Zone 14, WGS 84, lat-lon, 
etc. You can usually determine the coordinate system and datum of your GIS file by 
displaying it in your GIS. The exception to this rule is when you import a shapefile that 
includes a PRJ file. When importing such a shapefile, MobileMapper Office reads the 
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PRJ file and automatically sets the Coordinates in… field accordingly. However, 
MobileMapper Office must already support this coordinate system. If the PRJ file refers 
to a coordinate system not supported by MobileMapper Office, you should create a new 
coordinate system by importing the PRJ file. To do this, go to the main menu bar and 
click on Options > Browse Coordinate Systems. Then click the Import icon. Select 
PRJ as the Files of type, browse to the desired PRJ file and click Open. 
 
When I try to create a background map I see an error message 
telling me that the map cannot contain two layers with the 
same name. What does this mean? 
You cannot import into a background map two layers with identical names. This is case 
insensitive. For example, if the background map already contains a layer named "Park," 
you cannot import another layer named “PARK” or "park." 
 
How do I display a previously created background map in 
MobileMapper Office? 
When you click on Tools > Background Maps, you see a window that lists all the 
background maps that you have created. (The first time you open this tool, it will be 
empty because MobileMapper Office does not ship with any background maps other than 
the world map that is always displayed on the map screen.)  To select a map, just click on 
its name and then click the Attach button. This will cause a paper clip icon to appear next 
the name. When you click the OK button, you should see the map on MobileMapper 
Office's map screen. You can also detach a selected map. 
 
How do I remove a background map from display? 
Select Tools > Background Maps and click the Detach button. This will remove the 
paper clip icon next the name. When you click the OK button, there will not be any 
background map displayed on the map screen. 
 
How do I edit a background map? 
Click Tools > Background Maps, select Vector or Raster and click the Map Editor 
button. Click File > Open to select the name of the map you want to edit. After you have 
edited the file, remember to save it by clicking on File > Save or File > Save as. Then 
click the Operations > Create Map option  
 
I tried to upload a vector-based background map to the 
MobileMapper Pro receiver and the software told me it couldn’t 
connect to the unit on COM1. What should I do? 
Highlight the COM1 port on the Settings window and click Test. When the utility finds 
the receiver, click OK and click the Next button on the Upload Wizard-Checking GPS 
window. If MobileMapper Office still cannot find the receiver, your PC’s COM1 port is 
probably reserved by another application – even one that is running in the background. 
You must disable this application’s communication on the COM1 port. 
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What should I do if I see the world map instead of the selected 
background map? 
This can occur for many reasons. These are the most common causes: 
- The GIS file you imported to create the map was in a different coordinate 

system/datum from the one you indicated upon import  
- The job file and the background map are in different locations and their extents do 

not overlap 
- The background map is corrupted for some reason and should be edited or 

regenerated 
 
What is the significance of the number in the Map Editor 
utility’s Map Scale field? 
First of all, the number in the Map Scale field is the denominator of a map scale ratio. 
This means that the higher this number, the smaller the scale, and vice versa. 
MobileMapper Office allows only a set number of scales that you can choose from by 
clicking on the field. If you are new to cartography, it is helpful to think of these numbers 
as altitudes at which you are viewing the surface of the Earth represented by the map. 
When you choose a scale value you are telling MobileMapper Office to not display the 
background map (or a specific layer in the background map) if you zoom out beyond this 
“altitude” above which the contents of this background map will NOT be displayed on 
the Map Display area or on the handheld screen. Instead you will see a rectangular 
outline of where the background map is. This allows you to move the map cursor to other 
locations much more quickly because you do not have to “repaint” the background map. 
Using a default scale of 1:100,000 or greater (e.g. 1:50,000), especially for big maps, will 
speed up map display. 
 
What is the significance of the map scales I can set for 
individual layers making up the background map? 
The map scale for individual layers works the same way in that if you zoom out beyond 
the scale indicated for one layer, the contents of that layer will disappear. This allows you 
to make certain features disappear from the map when you zoom out while leaving others 
on display. For example, if you create a background map consisting of a roads layer and a 
manhole layer with the scale both set to 1:100,000, if you zoom out to 1:99,000 you will 
see all the roads but at this “altitude” the manholes will appear as solid lines obscuring 
the roads. If you set the scale of the map and the roads to 1:100,000 but set the manhole 
layer’s scale to 1:10,000 you will see only the roads until you zoom in closer than 
1:10,000. At this altitude, the manholes will be displayed as what they are – distinct point 
features. 
 
How does the map scale I set in MobileMapper Office’s vector 
map editor correspond to the map scale in the receiver? 
The default scale for a (vector) background map in the MobileMapper Pro/ProMark3 
receiver now varies according to the map scale selected in MobileMapper Office’s 
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Background Map Editor. A map created in MobileMapper Office with a scale of 
1:1,000,000 will be initially displayed in the receiver at a lower scale than a map created 
in MobileMapper Office with a scale of 1:50,000. The default scale for a layer in a 
background map is 1:100,000. This corresponds to the default scale formerly used in the 
MobileMapper Pro/ProMark3 receiver (scale bar corresponds to 140m on the map 
screen). If you increase a layer’s scale in MobileMapper Office to greater than 1:100,000 
(e.g., 1:50,000), this layer will be visible on the receiver at greater scale (e.g., scale 
bar corresponds to 70m on the map screen). And if you set a layer’s scale in 
MobileMapper Office to less than 1:100,000, (e.g., 1:200,000), the layer will 
become visible on MM at lower scale (e.g., scale bar corresponds to 350m). You must be 
careful now since if you give a low scale (e.g., 1:1,000,000) for a high-density layer (e.g., 
streets), the receiver can slow down significantly while drawing the layer. On the other 
hand, for it can be useful to give layers like rivers or highways a low scale (e.g., 
1:1,000,000). 
 
I have attached the background map I want to display, but I 
cannot see it on MobileMapper Office's map screen. How do I 
display it? 
All you have to do is zoom in to a scale that is larger than the scale you set for the 
background map when you created it. For example, if you used the default scale 
1:100,000 in the Map Scale field of the Map Editor window and if the scale of the map 
display screen is set at 1:100,001, you won’t see the background map. To reset the scale 
to a larger number (i.e., to a smaller ratio), click on View > Zoom In or on the Zoom In 
icon (a magnifying glass with a + symbol in it). You can also click the down arrow next 
to the Set Scale box in the icon bar and select the “Zoom to…” option at the bottom. 
Then type in a number that is smaller than the scale number you selected in the Map 
Scale field of the Create Map utility. 
 
How do I upload a background map to the receiver? 
Make sure that the background map is displayed on MobileMapper Office’s map screen. 
It makes no difference if a job file is simultaneously displayed. Click on File > Upload to 
GPS and then click on Background Map. If you have not selected a region, the entire 
background map will be uploaded. You are then given a choice of uploading the map (1) 
directly to the receiver via the serial cable, (2) to the receiver’s SD card when it is placed 
in an SD card reader (this is much faster for large background maps) or (3) to a location 
on your PC’s hard drive. If you select the SD card reader option, leave the card in the 
reader for 10 - 30 seconds after MobileMapper Office indicates that the transfer is 
complete. Some card readers require this extra time to save the uploaded file to the card 
even though the transfer is complete.  
 
Can I upload a MobileMapper Office background map to any 
other type of receiver? 
Maps – as well as waypoints, route and jobs - created by MobileMapper Office can be 
displayed only in MobileMapper Pro and ProMark3 receivers. 
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What types of file extensions are created when I upload a 
background map to the receiver? 
The background map upload process does not upload the file you created (with .mmp file 
extension). Rather, the upload process reformats this map file to optimize its performance 
in the receiver. The optimized map has an .img file extension. To allow compatibility 
with Magellan’s MapSend product, the .img file is automatically named 
DETAIL00.IMG. Each will automatically receive its own 2-digit number in the file 
name. This will allow you to upload a number of regions of the same background map 
and so use smaller amount of data at one time, thereby increasing map display 
performance. 
 
What is the difference between an .MMP file and an .IMG file? 
MobileMapper Office optimizes the .MMP format for display. An .IMG file is in a 
format optimized for display by the MobileMapper Pro/ProMark3 receiver. The content 
is the same. .  
 
Uploading background maps takes a lot of time with the data 
cable. Is there any way to speed this process? 
1. The first thing you should do is to restrict the amount of data you want to upload to 

the receiver. You do this by including in your background maps only those layers that 
you will need to use in the field. 

2. You can also dramatically decrease the upload time and simultaneously improve map 
display performance in the receiver by uploading the smallest necessary portion of a 
background map. These subsets of MobileMapper background maps are called 
“regions.” When you upload a region instead of the whole map, you do not in any 
way affect the whole map. It remains intact should you ever want to upload a 
different region. The answer to the question immediate above this one tells you how 
to create a background map region. 

3. The most effective way to upload a map to your receiver is by selecting the Upload 
to SD Card option after clicking on File > Upload to GPS > Background Maps. 
Uploading to the receiver uses a serial connection that is inherently much slower than 
communicating with an SD card receiver that typically uses a USB connection. 
Uploading anything to the receiver is faster via an SD card reader. 

 
I uploaded one map to the receiver via its serial cable. When I 
uploaded a second map via the cable, the first map was erased. 
Why did this happen? 
MobileMapper Office allows you to upload only one map at a time to the receiver via the 
serial cable. If you upload map1.mmp via the serial cable, it is automatically renamed 
DETAIL00.IMG on the receiver’s SD card. If you then upload map2.mmp, it will be also 
be uploaded as DETAIL00.IMG and with overwrite the first map and thereby save 
memory on the SD card. However, as SD cards become larger, this feature becomes less 
desirable, so there is a way to get around this restriction (see the next FAQ). 
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How do I upload multiple maps to my receiver? 
You can upload multiple maps to the receiver by placing its SD card in an SD card reader 
and selecting the SD card reader option on the Upload Wizard. Each file uploaded 
directly to the SD card keeps its original name when it is formatted for the receiver and 
given the .IMG extension.  
 
What factors limits the size of a background map that can be 
uploaded to the MobileMapper Pro/ProMark3 receiver? 
Because entire background maps must be loaded into the receiver’s system memory 
during display, you cannot upload a map larger than the size of this system memory, i.e. 
about 4 MB in the MobileMapper Pro and about 50 MB in the ProMark3. Because 
background maps (as well as jobs, feature libraries, waypoint and route files, etc.) reside 
on the receiver’s SD card, you cannot upload a map that is larger than what is available. 
This explains why can be impossible to upload, for example, a 5 MB background map to 
a MobileMapper Pro’s SD card that has 16 MB of available memory. 
 
How can I tell if a background map is too large before 
attempting to upload it? 
The best way to see if a background map is too big or complex to upload is to try to 
upload it. If MobileMapper Office tells you the map is too large, you can cut it into two 
or more regions and upload as many of these regions as you want into the receiver. As 
you move out of one region, you can switch to the region you are entering by pressing 
MENU> Setup > Select Map, highlighting the Detail Map field, pressing Enter and 
selecting the map or map region you wish to display. 
 
How do I create a region of a background map and upload it to 
the receiver? 
With the background map displayed, click on Tools > Create Map Region. Then click 
and drag the cursor to create a rectangular subsection of the background map for upload. 
You will note that an approximation of the number of bytes comprised in this region is 
displayed. When you are satisfied with the size and extent of this region, right click the 
mouse and the region will be filled. This indicates that region has been created. When 
you upload the background map to the receiver, the upload utility will ask if this is the 
region you want to upload. 
 
When I zoom in all the way on the MobileMapper Pro receiver, 
why do the background map’s features appear “jagged?” 
MobileMapper background maps can be several megabytes in size, whereas job files are 
typically much smaller. This means that the receiver’s map engine will take much more 
time to display a background map than a job file. One way to speed up the display of a 
background map display is to reduce its resolution. When you zoom in all the way on the 
receiver, a background map’s lower level of resolution (compared to that of a job file) 
can give straight lines a jagged appearance. This jaggedness is artificial and does not 
reflect the accuracy of GPS positions. 
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Why is the selection of map symbols for point features in 
background maps different from the selection for feature 
libraries and job files? 
It is better to use two different sets of point symbols so you can distinguish a feature on 
the background map from a feature in a job file. A feature on a background map is just a 
visible navigation and reference guide that is uneditable. You would not want to confuse 
such a feature with a feature in a job file that is an editable, geo-referenced entry in a 
database. 
 
The GIS file that I used to create the background map shows 
labels for the various features. Why don’t these labels appear 
on the map when viewed with the MobileMapper Pro/ProMark3 
receiver? 
The receiver does not display feature labels on its map screen because this would make it 
harder to read the labels of mapped GIS features when you are logging or reviewing a job 
file. However, if you move the map cursor over a background map’s feature, the attribute 
you selected for display when you created the background map (see page one) will be 
displayed in the box underlying the map screen. 
 
I can see a rectangular outline on my receiver’s map screen. 
What is this? 
This rectangle is called a background map extent frame. It outlines the extent of a 
background map once it is uploaded to the receiver. It is visible with all background maps 
in the receiver as a sort of picture frame so you can clearly see what portion of the map 
screen lies within the background map and what portion lies outside. 

 
Why is this background map extent frame sometimes blank? 
If there is an error in creating a background map, it is possible to upload it to the receiver 
– together with its extent frame – but impossible to display it. All you see is the rectangle. 
In addition, it is possible to create background maps using white features. While these 
features appear on the colored MobileMapper Office map screen, they are invisible on the 
receiver’s white map screen. When creating a background map you will use in the 
receiver, you should ensure that none of the feature layers uses a white symbol, line or 
area perimeter/fill. 
 
How can I remove the background map (and its extent frame) 
from the receiver’s map view? 
When you remove a background map from view, you also remove the map extent frame. 
On your receiver, press the Menu button and select the Setup option. Move the cursor 
down to Select Map and press Enter. Highlight the Detail Map field and write down the 
name of the detail map. Then press the Enter button and select the Detail Map Off 
option. Press Enter again. You will be on the Select Map screen again where you should 
highlight Save at the bottom of the screen and press Enter. 
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How can I delete a background map (and its extent frame) 
from the receiver? 
First remove the background map from the display (see the instructions in the previous 
question). Press ESC and then the Menu button. Now select the Delete Files option and 
delete the background map (an .IMG file) that was listed in the Detail Map field. 
 
What other software applications can write background maps 
to the MobileMapper Pro receiver? 
In addition to MobileMapper Office, you can use the following Magellan MapSend 
products to create and upload maps into the MobileMapper Pro receiver (but not to the 
ProMark3 receiver): 
- MapSend DirectRoute 
- MapSend Streets and Destinations 
- MapSend Topo and Topo 3D 
- MapSend Worldwide 
The MobileMapper Pro is not compatible with MapSend BlueNav marine charts. These 
charts reside on read-only SD cards. The MobileMapper Pro receiver logs data to SD 
cards and so works only with read/write cards. 
 
I created a background map using a georeferenced raster 
image in UTM coordinates and the map covers a large part of 
the globe.  What happened? 
The raster image probably was not georeferenced in a way that MMO's Background Map 
tool could read it correctly.  When MMO reads a georeferenced raster image’s reference 
point coordinates, it expects to see the northings first and the eastings second. However, 
some images are georeferenced with the eastings first and the northings second.  When 
this happens, the map MMO creates will be extremely large. To fix this, do the following: 
 
A. Print the Image Georeference Properties screen 

Open the map project and double-click on the layer that you think has switched the 
northings and eastings. Use a screen printing utility to print the Image Georeference 
Properties window or click inside the window and press the Print Screen key on 
your keyboard. Open a new document in Word or a new email message and 
simultaneously press Ctrl+V to paste the image into the Word document or email. 
Then print the Word document or email for easy reference. 

 
B. Re-register the image manually, switching the northings and eastings 

Click OK on the Image Georeference Properties window to close it. Click the Add 
Reference Point icon at the far left of the Image Georeference tool's tool bar. You 
will be asked if you are sure you want to re-register the image. Click Yes/OK. Click 
the cross hair cursor on the NW corner (the "left top" corner) of the image. This 
displays the Reference Point window.  Input the second coordinate listed on the 
Image Georeference Properties window into the "left top" point's northing field on 
the Reference Point window. Then input the first coordinate for the easting. Follow 
the same procedure for the SW corner of the map (called the “Left Bottom” 
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coordinates on the Image Georeference Properties window), the SE corner and then 
the NW corner. 

 
C. Test the georeferencing to see if you made an obvious mistake 

Click the Test Reference Points icon on the Image Georeference tool's tool bar. 
 
D. Exit the Image Georeference window. 
 
E. Remake the background map 

Either click the Raster Map Editor's Create Raster Map icon or click 
Operations>Create Map. 

 
F. Save the map 

Click File>Save As and save this as a new raster map project (.rmp) file or File>Save 
to overwrite the existing file. 

 
G. Exit the Raster Map Editor window and the Background Map tool. 


